.NET Frameworkをアンインストールしてはいけません! | サラリーマンの副業奮闘記

.NET Frameworkをアンインストールしてはいけません! | サラリーマンの副業奮闘記 記事一覧

.NET Frameworkをアンインストールしてはいけません!

まいど、吉田屋です。


「.NET Framework」ってご存知ですか?


あなたのPCにもインストールされているはずです。
メニューバーの「スタート」から「コントロールパネル」を選んで、
「プログラムの追加と削除」を開いてみてください。


いろんなバージョンがインストールされてますよね。
バージョン1.1と3.5はありましたか?


ラッキーでしたね。
でも、3.5があるからといって1.1を消してはいけません!!





私のPCにインストールされている「.NET Framework」です。

NET Frmamework


普通のソフトは、だいたい上位互換性がありますから、
上位のバージョンがあればそれより下のバージョンは要らないと思っちゃいます。


でも、「.NET Framework」は、2.0以降は、一応上位互換性がある
と言われていますが、1.1と2.0では上位互換性がないので注意が必要です。


ですから、あなたのPCに”幸運にも”インストールされている
「.NET Framework」は、削除しないようにしましょう。


ここで、”幸運にも”と書いたのは、「.NET Framework」の
インストールは、一度失敗するととてつもなく面倒になるからです。


お時間あれば、”.NET Framework インストール 失敗”などで
検索してみてください。


Yahoo!で42万件もヒットしました!


私は、その”幸運”な方の部類だったので、まったく苦労してません。
インストーラーでボタンをクリックした記憶しかないです。


先日、私の商材「ネット時代の新★手引書シリーズ」の購入者さんから、
「.NET Frameworkがどうしてもインストールできないので、どうしたらよいのか」
という問い合わせをいただいて、初めてその大変さを知りました。


そもそも「.NET Framework」ってなんでしょう?

だいたい、「.」で始まるファイル名って怪しくないですか?


『マイクロソフトが開発したWebサービスやWebアプリケーションなどを実行するための
プラットフォーム』
だそうです???


要するに、違うプログラミング言語で作られたプログラムが、共通の部品を
利用出来るようにしたもの、です。


最近では、.NETの環境で動作するソフトが増えてきてます。


私が商材の中で紹介している、PDF化ソフトのPrimoPDFや、登録情報の
自動入力ソフトaiBARなどのフリーソフトも「.NET Framework」がないと
動きません。


ここで、一つやっかいなことがあります。


「.NET Framework」が必要な場合のエラーメッセージが、
”.NET Frameworkをインストールしてください。”と出れば、
誰も困らないのですが、全然関係ない文言が表示されるんです。


例えば、XPの場合、
『アプリケーションを正しく初期化できませんでした。
[OK]をクリックしてアプリケーションを終了してください。』
というエラーメッセージが出ます。


先程の購入者さんの場合は、
『16ビットMS-DOSサブシステム NTVDM CPUは不正命令を検出しました。』
というエラーメッセージが出たそうです。


意味知りたいですか?


そういう勉強熱心な方はこちらをご覧ください。
↓ ↓ ↓
http://detail.chiebukuro.yahoo.co.jp/qa/question_detail/q107154540



これで、
「ふむ、ふむ、.NET Frameworkをインストールせねば。」
と思う人は、いくらなんでもいないでしょう。(笑


有料の商品でしたら、インストールガイドに「.NET Framework」を
あらかじめインストールするよう注意書きがあるでしょう。


しかし、フリーソフトの場合、それが書いてないことがあります。
で、ハマっちゃう訳ですね。


さらに事態を複雑にしている問題があります。


「.NET Framework」には多くのバージョンに加えて、Service Packなどの
いろいろな追加パッチファイルがあります。


このインストールの順番を間違えたりすると、次のバージョンがインストールできなくなる
という問題が発生します。


それが、上の42万件になるわけですね。(笑


この問題を回避するには、まずWindows Updateを使うことでしょう。
↓ ↓ ↓
http://dl.xtrm.jp/dnfw_inst.htm



更に必要があれば、各バージョンを個別にインストールしなければいけません。
その場合、更新プログラムをインストールする時に、エラーが発生するかもしれません。


こちらをご覧ください。
↓ ↓ ↓
マイクロソフトサポートオンライン


読むだけで疲れますね。(笑


「.NET Framework 3.5」には、2.0のService Pack 1と3.0のService Pack 1が
含まれるそうです。


最新バージョンのインストーラーには、それ以前のバージョンとパッチファイルを全部、
入れといてもらえませんかねぇ・・・


こんな思いをしないためにも、あなたのPCに”幸運にも”入っている
「.NET Framework」は、絶対アンインスールしないようにしましょうね。


※『.NET Framework 4』のインストール方法はこちら。
↓ ↓ ↓

.NET Framework 4はSIRIUSのためにもインストールしておきましょう


※インストールのトラブルではまっちゃった方。
↓ ↓ ↓
『いっそのこと「.NET Framework」を全削除してインストールし直しませんか』


※『.NET Framework 4.5 RC』のインストールで迷っている方。
↓ ↓ ↓
『.NET Framework 4.5 RCはWindows XPとVistaではサポートされません』




comments(10)trackbacks(0)|2010.01.19 Tuesday | category:├ .NET Framework
このブログで人気のある記事を読む

ブログパーツ
このブログで人気のある記事を読む

コメント








   

吉田屋さん、こんばんは。チイです。

ご訪問と応援+優しいお気持ち=いつもありがとうございますm(_ _)m


Ver.の古いものって捨てたくなります私も。

「.NET Framework」・・・
捨てちゃダメなんですね。
危ない危ない^^;

過去にやっちゃいけないこと
している分、慎重になりますが、
うっかりやりそうな私。

気をつけまーす^^

心をこめて、応援のポチッ♪を贈ります☆〃

稼ぐ魔法の小槌☆8P(ハッピー)ピエロの考察・ブログ Ver. 2010/01/20 9:11 PM

チイさん、いらっしゃい。

そうなんですよね。
私も古いバージョンを捨てなかったのは
運が良かっただけです。

それにしてもマイクロソフトの正規品で
ありながら、こんなに複雑なのは、
困ったものですねぇ。

吉田屋 2010/01/20 10:38 PM

吉田屋さん

はじめまして、中年夫婦と申します。

NET Framework さっそく確認してみました。 「3.5」 しかありませんでした^^;


現在、「ネット時代の新★手引書シリーズ」のご縁で、購入者通信を拝読しております。

また、おじゃまさせてください。

応援済みです^^

中年夫婦 2010/01/20 11:19 PM

中年夫婦さん、いらっしゃいませ。

購入者の方からのコメントは、
初めてかも知れません。

うれし〜♪

購入者通信は、必要なときだけ
不定期に発行していますので、
是非、こちらのブログを参考に
なさってください。

ここが、「ネット時代の新★手引書
シリーズ」中級編リアルタイム版です!!

吉田屋 2010/01/21 12:23 AM

吉田屋様

初めましてタッチと申します。

どうぞ宜しくお願い申し上げます。

今日は吉田屋様のメルマガやブログで勉強させていただきました。

私のパソコンはWindowsXPでPCにインストールされている「.NET 」と付く物はありませんでした。
パソコンが古い為でしょうか?

新しい物をインストールすると今までのものに不都合が出てきませんでしょうか?

不安です。

今日は吉田屋様の色々拝見して、初心者の私にもわかりやすく、「私にもネットで収入が得られるようになれるかな?」と思いました。

これからもどうぞ宜しくお願い申し上げます。

木下達子 2010/12/25 11:00 PM

タッチさん、いらっしゃい。

.NETはあらかじめインストールされているものではないので、
アップデートなどを定期的にやっていない方では、
入っていない可能性もありますね。

全てのソフトが.NETを必要としているわけではありませんから、
今、不都合なければ新たに追加インストールする必要はありません。

バージョンの新しいものを入れたからといって、
不都合は起きませんが、不要なものを
敢えてインストールすることはないでしょう。

ネットで収入を得ることはリアルのビジネスに比べれば、
やっぱり簡単だと思いますね。

タッチさんもこれから楽しく稼いでいけたらいいですね。

吉田屋 2010/12/26 12:18 AM

.NET Frameworkについては、Windows XPのクリーンインストール後の難関でしたが、いろいろ参考になりました。
メルマガも読者になります。

onion 2011/05/24 8:49 PM

onionさん、いらっしゃい。

.NET Frameworkは、
はまる方がまだまだ多いようですね。

少しでもお役に立てて、
よかったです。

メルマガでも、
役立つ情報を発信していきますので、
宜しくお願いします。

吉田屋 2011/05/24 10:16 PM

.NET Frameworksですが、Windows7の64ビット版だと
1.1
3.5の一部

だけしかインストールできないみたいです。
64ビットですからねぇ。
4は2とかを含有しているとのことでした。
1.1は不整合が起きるから消せと言われるので
Win7 64ビットでは、たぶん4だけあれば大丈夫みたい。
SIRIUSのセールスレターにも.NETの2が必要と書いてありますが
実際は4が入っていれば大丈夫とのことでした(販売者さんより)


それよりも、7のサービスパック1が当たらなくて
えらく苦労しました。
ネットで調べまくって、レジストリーに修正パッチ当てて、やっとまともにできました。
なんとかしてくれーーー

石山虎乃進 2011/06/13 6:36 PM

石山さん、いらっしゃい。

64ビットに関する貴重な情報、
ありがとうございました。

私はまだ32ビットの型落ちPCを使っているので、
検証のしようがないのですが、
新たな情報がありましたら、是非、
皆さんと共有させてください。

Windows7は、いろいろな悪評を聞きますね。(笑

まあ、Windowsの不具合については、
既に慣れっこになってるところもありますが。

吉田屋 2011/06/14 2:11 AM

トラックバック
この記事のトラックバックURL:

月間アーカイブ



(最近の記事一覧)
Copyright © 2018  .NET Frameworkをアンインストールしてはいけません! | サラリーマンの副業奮闘記 All Rights Reserved.
当サイトのテキストや画像等すべての転載転用・商用販売を固く禁じます
Designed by SEOテンプレートKAETEN X